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Thank you for your interest in SAMSON! 

In this Quick Start Guide, you will find all the information you need to 
get up to speed with SAMSON.  

Why did you start SAMSON? 

To make it easier for people in nanoscience and nanotechnology to 

collaborate with each other.  

We mean ‘nanoscience and nanotechnology’ in the widest possible 
sense: any science and technology performed at the atomic scale. 

What is SAMSON? 

SAMSON is an integrated platform for molecular design, with an 
open architecture that makes it suitable for drug design, life science, 
materials, physics, nanoscience, electronics, chemistry, education, and 

every combination.  

SAMSON stands for: 
“Software for Adaptive Modeling and Simulation of Nanosystems”. 

What are SAMSON Extensions? 

SAMSON Extensions are modules for SAMSON, developed with the 
SAMSON Software Development Kit. SAMSON Extensions may 
contain apps, editors, models, parsers, etc. for a wide variety of tasks. 

You can customize SAMSON by adding SAMSON Extensions from 
SAMSON Connect. Free SAMSON Extensions can be added in one 
click. Paid SAMSON Extensions can be subscribed to and cancelled 

anytime. 

You can also develop your own SAMSON Extensions and distribute 
them on SAMSON Connect, for free or not. 

 

How do I load and save molecules and files? 

Use the Home menu. Opening and saving relies on importers and 
exporters provided in SAMSON Extensions. Default importers and 
exporters support the PDB, cif, mmtf, gro, mol2, sdf, sam (SAMSON), 

samx (SAMSON XML), and other formats. Add more from SAMSON 
Connect. 

How do I change the view? 

Hold right mouse button to rotate the view, hold mouse wheel (or right 

mouse button + Ctrl / Cmd) to translate it, mouse wheel to zoom in 
and out, use keyboard arrows (with and without Ctrl / Cmd, Alt), 
Shift + Space to center on the selection. 

Activate the compass in the viewport and use it to 
easily orient the view. 

How do I use editors? 

Editors react to mouse and keyboard events. Use editors to select, 

move, etc. nodes in the viewport. Select the active editor from the left-
side menu in the viewport. Default editors include: 

Select (R): left mouse button to select, left mouse button 

outside selected nodes to draw a rectangle and select nodes, 
Ctrl / Cmd to add nodes, Alt to remove nodes, right mouse 
button to show the context menu. 

Move editors (D, M, K): displace, translate, and rotate 

selected nodes in global or local coordinates. 

Add editor (A): add atoms, fragments, assemble assets to 
build molecules. See also: Bond editor, Charge editor. 

Measure editor (Ctrl / Cmd + M): display distances and 
angles between atoms, click Enter to add a label. 

You can find more editors on SAMSON Connect. 

How do I select nodes? 

Viewport: use a selection editor to select nodes in the viewport with 
the mouse, use the selection filter in the top-right corner of the 
viewport to control what can be highlighted and selected in the 

viewport.  

Document view:  click on nodes in the Document view to select them 

and highlight them in the viewport. Use Shift and Ctrl / Cmd to 
perform complex selections. Filter nodes by entering a string or a 
Node Specification Language expression. Press Enter to select.  

The bottom part of the Document view shows a selection summary. 
Click there to see possible contextual actions.  

Find command: use the Select > Find (Ctrl / Cmd + F) to perform 
selections with the Node Specification Language. 

How do I inspect nodes? 

Use the Inspector (Interface > Inspector, Ctrl / Cmd + 2) to 
view and edit the properties of selected nodes. Use the inspector 
controls to choose a) whether you inspect the descendants of the 

selected nodes as well, and b) whether you edit all selected nodes or 
only the last selected node. Use the filter to see matching attributes 
only. 

How do I customize visualizations? 

Add visual models to the document with the Visualization > 
Visual model menu (Ctrl / Cmd + Shift + V) or the toolbar menu. 

Visual models are applied to the current selection (or the whole 
document if nothing is selected). Default visual models include 
Licorice, Lines, etc. Add more types of visual models from SAMSON 

Connect. To colorize, click on nodes (or click on the selection 
summary) and use Material from the toolbar menu to apply color 
schemes to nodes or use the Visualization > Material menu. Use 
the Interface > Preferences menu for advanced rendering options. 

Use the checkbox next to each node in the Document view to hide / 
show it in the viewport. 

Use default Visual presets (Visualization > Visual model >  
Presets) or create your own to visualize molecular systems. 

How do I perform interactive simulations? 

Select the nodes you want to simulate (or nothing if you want to 
simulate everything) and use the Add > Simulator context menu or 

the Home > Add simulator menu (Ctrl / Cmd + Shift + M). 
Choose an interaction model and state updater (see below). 

Use the Home menu to start and stop interactive simulation. Use 
selection editors to move atoms during simulation. 

How do I use apps? 

Apps are generic tools with a Graphical User Interface. Some 
Apps are provided by default with SAMSON. You can find and add more 

Apps on SAMSON Connect > Marketplace.  

Open Apps from the App menu or from the Find commands, apps.  

SAMSON’s Graphical User Interface  

(1) Menu, (2) Viewport, (3) Document view, (4) History, (5) Inspector, 

(6) Status bar, (7) Assets, (8) Animator 
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How are SAMSON documents organized? 

SAMSON documents are hierarchies of SAMSON nodes. A 
document hierarchy is visible in the Document view. Documents may 
contain folders, files, cameras, models (structural, visual, dynamical, 

interaction, property), simulators, labels, notes, conformations, paths, 
and node groups. Several node types are used to organize, view, 
present, and annotate a document: 

Camera: used to produce 3D views in the viewport. 

Documents may contain multiple cameras. The viewport 
reflects the active one.  

Folder: used to organize nodes and embed other folders and 

files. Folders may contain other folders, files, notes, cameras, 
models (structural, visual, dynamical, interaction, property), 
simulators, labels, conformations, paths, render presets, and 
node groups.  

File: used to embed files. Embed files or folders with files by 
importing them in SAMSON via Home menu. 

Script: a Python script to perform various tasks using the 

SAMSON Python API. Add a script using the Edit > Script 
menu. 

Note: used to annotate documents, folders, results. Add a 
note using the Edit > Note menu. Use the Inspector to view 

and modify notes. 

Node group: a node group is a saved selection. Use the 
Select > Group menu (G) to create a group from the current 

selection. Double click the group in the Document view to 
restore the saved selection. Right click for more options (add 
to selection, etc.).  

Label: used to annotate nodes. Labels may be created by 

editors (for example the ‘Measure’ editor), apps, etc. 
Customize the rendering of labels from the Interface > 
Preferences menu. 

Presentation: used to create and store a presentation with 
animations. Use the Animation menu to create a presentation 
and add new animation effects. Use the Animator (Ctrl / 
Cmd + 7) to add and modify animations.  

Five node types represent the five categories of models: 

Structural model: used to describe the geometry and 
topology of molecules. A structural model may only contain 
structural nodes. Create structural models by importing files 

with the Home > File menu (Ctrl / Cmd + O) or through 
editors and apps.  

Visual model: used to provide custom visual representations 
of other nodes. Add visual models to the document with the 
toolbar menu or the Visualization > Visual model menu 
(Ctrl / Cmd + Shift + V). Visual models are applied to the 

current selection or to the whole document if nothing is 
selected. Default visual models include Licorice, Ribbons, etc. 
You can find more types of visual models on SAMSON 
Connect. 

Dynamical model: used to describe the degrees of freedom 
in molecules. Dynamical models are particle systems: they 
associate one particle to each simulated atom, and each 

particle has three degrees of freedom (its x, y and z 
coordinates). Dynamical models are automatically added to the 
document when you add a simulator (see below). 

Interaction model: used to describe energies and forces 

inside a dynamical model. Choose interaction models when you 
add simulators (see below). The default interaction model is 
the Universal force field. You can find more interaction models 

on SAMSON Connect. 

Property model: used to describe properties outside the 
other four categories of models. Property models can be found 
in SAMSON Extensions on SAMSON Connect. 

Several node types are used to break down structural models into 
sub-structural components: 

Structural group: used to organize structural nodes. A 

structural group may contain atoms, backbones, bonds, chain, 
molecules, pseudo-atoms, residues, segments, side chains, 
and structural groups. 

Molecule: a molecule may contain structural groups, chains, 

segments, residues, atoms, pseudo-atoms, and bonds. 

Chain: a chain may contain structural groups, segments, 
residues, atoms, and bonds. 

Segment: a segment may contain atoms, bonds, structural 
groups, and residues. 

Residue: used to represent an amino acid or a nucleic acid. A 
residue may contain a backbone and a side chain. 

Backbone: used to represent an amino acid backbone or a 
nucleic acid backbone. A backbone may contain atoms and 
bonds. 

Side chain: used to represent an amino acid side chain or a 

nucleic acid side chain. A side chain may contain atoms and 
bonds. 

Atom: used to represent atoms (we are pretty sure you 
guessed), including coarse-grained atoms. In the Document 
view, atom icons are colored based on atom types.  

Bond: used to represent bonds. The two atoms that a bond 

connects can be accessed via the Inspector.  

Double-click on an atom or a bond to select and zoom on it.  

Two node types are used for simulation: 

Simulator: used to perform interactive or offline simulation. 

Add simulators to the document with the Edit > Add 
simulator menu (Ctrl / Cmd + Shift + M) or the Add > 
Simulator context menu. Choose the interaction model and 

the state updater you want to use. Simulators are applied to 
the current selection or to the whole document if nothing is 
selected. Use the Edit menu to start and stop interactive 
simulation.  

State updater: used to update simulations. State updaters 
are added to the document through simulators (see above). 
Default state updaters include ‘Interactive modeling’, ‘Steepest 

descent’, ‘Partitioned Euler’, etc. Add more state updaters from 
SAMSON Connect. 

Finally, two node types are used to save conformations and paths: 

Conformation: used to store positions of atoms and pseudo 

atoms. Use the Home > Store (S) to create a stored 
conformation. Double click on the conformation in the 
Document view to restore the saved positions.  

Path: used to store positions, velocities, forces, energy, and 
time along a path. Paths may be created by editors, apps, 
importers, etc. Double click on a path in the Document view 
to start and stop animating it. Use the context menu or the 

Inspector (Interface > Inspector, Ctrl / Cmd + 2) for 
more control. 

How do I find commands? How do I mark them as favorites? 

Use the Find everything on the top right part of the Menu. From 
there (and often directly from the menus themselves), you can mark 
commands, editors, and apps as favorites and find them from the 
Favorite menu. 

How do I learn more? 

Follow interactive tutorials in SAMSON: Help > Tutorials menu. 

For documentation, tutorials, the forum, etc., visit SAMSON Connect 
at https://www.samson-connect.net. 
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